summaryrefslogtreecommitdiff
path: root/dev-haskell/lifted-async/lifted-async-0.10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/lifted-async/lifted-async-0.10.2.ebuild')
-rw-r--r--dev-haskell/lifted-async/lifted-async-0.10.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/lifted-async/lifted-async-0.10.2.ebuild b/dev-haskell/lifted-async/lifted-async-0.10.2.ebuild
new file mode 100644
index 000000000000..8d24a56ee772
--- /dev/null
+++ b/dev-haskell/lifted-async/lifted-async-0.10.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Run lifted IO operations asynchronously and wait for their results"
+HOMEPAGE="https://github.com/maoe/lifted-async"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/async-2.2:=[profile?] <dev-haskell/async-2.3:=[profile?]
+ >=dev-haskell/constraints-0.2:=[profile?] <dev-haskell/constraints-0.14:=[profile?]
+ >=dev-haskell/lifted-base-0.2:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ >=dev-haskell/monad-control-1.0:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
+ >=dev-haskell/transformers-base-0.4:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/hunit
+ dev-haskell/mtl
+ dev-haskell/tasty
+ <dev-haskell/tasty-expected-failure-0.13
+ >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.11
+ dev-haskell/tasty-th )
+"