summaryrefslogtreecommitdiff
path: root/dev-haskell/integer-logarithms/integer-logarithms-1.0.3.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/integer-logarithms/integer-logarithms-1.0.3.1-r1.ebuild')
-rw-r--r--dev-haskell/integer-logarithms/integer-logarithms-1.0.3.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/integer-logarithms/integer-logarithms-1.0.3.1-r1.ebuild b/dev-haskell/integer-logarithms/integer-logarithms-1.0.3.1-r1.ebuild
new file mode 100644
index 000000000000..b4130a9ab192
--- /dev/null
+++ b/dev-haskell/integer-logarithms/integer-logarithms-1.0.3.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -check-bounds
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Integer logarithms"
+HOMEPAGE="https://github.com/haskellari/integer-logarithms"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+#circular dependency: scientific -> integer-logarithms -> tasty -> scientific
+RESTRICT=test
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1"
+# test? ( >=dev-haskell/quickcheck-2.14.1 <dev-haskell/quickcheck-2.15
+# >=dev-haskell/smallcheck-1.2 <dev-haskell/smallcheck-1.3
+# >=dev-haskell/tasty-0.10 <dev-haskell/tasty-1.4
+# >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.11
+# >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11
+# >=dev-haskell/tasty-smallcheck-0.8 <dev-haskell/tasty-smallcheck-0.9 )
+# "
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'ghc-bignum >=1.0 && <1.1' 'ghc-bignum >=1.0'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-check-bounds
+}