summaryrefslogtreecommitdiff
path: root/dev-haskell/hxt/hxt-9.3.1.22.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hxt/hxt-9.3.1.22.ebuild')
-rw-r--r--dev-haskell/hxt/hxt-9.3.1.22.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/hxt/hxt-9.3.1.22.ebuild b/dev-haskell/hxt/hxt-9.3.1.22.ebuild
new file mode 100644
index 000000000000..aac5424955fc
--- /dev/null
+++ b/dev-haskell/hxt/hxt-9.3.1.22.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: +network-uri
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A collection of tools for processing XML with Haskell"
+HOMEPAGE="https://github.com/UweSchmidt/hxt"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="profile"
+
+RDEPEND=">=dev-haskell/hxt-charproperties-9.1:=[profile?]
+ >=dev-haskell/hxt-regex-xmlschema-9.2:=[profile?]
+ >=dev-haskell/hxt-unicode-9.0.1:=[profile?]
+ >=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?]
+ >=dev-haskell/parsec-2.1:=[profile?] <dev-haskell/parsec-4:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=network-uri \
+ $(cabal_flag profile profile)
+}