summaryrefslogtreecommitdiff
path: root/dev-haskell/hxt-regex-xmlschema/hxt-regex-xmlschema-9.2.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hxt-regex-xmlschema/hxt-regex-xmlschema-9.2.0.7.ebuild')
-rw-r--r--dev-haskell/hxt-regex-xmlschema/hxt-regex-xmlschema-9.2.0.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/hxt-regex-xmlschema/hxt-regex-xmlschema-9.2.0.7.ebuild b/dev-haskell/hxt-regex-xmlschema/hxt-regex-xmlschema-9.2.0.7.ebuild
new file mode 100644
index 000000000000..497a0ef637a1
--- /dev/null
+++ b/dev-haskell/hxt-regex-xmlschema/hxt-regex-xmlschema-9.2.0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A regular expression library for W3C XML Schema regular expressions"
+HOMEPAGE="https://www.haskell.org/haskellwiki/Regular_expressions_for_XML_Schema"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="profile"
+
+RDEPEND=">=dev-haskell/hxt-charproperties-9:=[profile?]
+ >=dev-haskell/parsec-2.1:=[profile?] <dev-haskell/parsec-4:=[profile?]
+ >=dev-haskell/text-0.10:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/hunit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag profile profile)
+}