summaryrefslogtreecommitdiff
path: root/dev-haskell/http-common/http-common-0.8.3.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/http-common/http-common-0.8.3.4.ebuild')
-rw-r--r--dev-haskell/http-common/http-common-0.8.3.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/http-common/http-common-0.8.3.4.ebuild b/dev-haskell/http-common/http-common-0.8.3.4.ebuild
new file mode 100644
index 000000000000..33969bd87820
--- /dev/null
+++ b/dev-haskell/http-common/http-common-0.8.3.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Common types for HTTP clients and servers"
+HOMEPAGE="https://github.com/aesiniath/http-common"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="dev-haskell/base64-bytestring:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/network:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"