summaryrefslogtreecommitdiff
path: root/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hslua-objectorientation/hslua-objectorientation-2.1.0.ebuild')
-rw-r--r--dev-haskell/hslua-objectorientation/hslua-objectorientation-2.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.1.0.ebuild b/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.1.0.ebuild
new file mode 100644
index 000000000000..cd06e87a53ed
--- /dev/null
+++ b/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Object orientation tools for HsLua"
+HOMEPAGE="https://hslua.org/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/hslua-core-2.1:=[profile?] <dev-haskell/hslua-core-2.2:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.1:=[profile?] <dev-haskell/hslua-marshalling-2.2:=[profile?]
+ >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/text-1.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/lua-arbitrary-1.0
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hslua-1.0
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"