summaryrefslogtreecommitdiff
path: root/dev-haskell/hexpat/hexpat-0.20.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hexpat/hexpat-0.20.13.ebuild')
-rw-r--r--dev-haskell/hexpat/hexpat-0.20.13.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-haskell/hexpat/hexpat-0.20.13.ebuild b/dev-haskell/hexpat/hexpat-0.20.13.ebuild
index 01a2c7198d8b..6bdd54151798 100644
--- a/dev-haskell/hexpat/hexpat-0.20.13.ebuild
+++ b/dev-haskell/hexpat/hexpat-0.20.13.ebuild
@@ -1,34 +1,33 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-# ebuild generated by hackport 0.5.3.9999
-#hackport: flags: bundle:bundled-expat
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: -bundle
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="XML parser/formatter based on expat"
-HOMEPAGE="http://haskell.org/haskellwiki/Hexpat/"
+HOMEPAGE="https://haskell.org/haskellwiki/Hexpat/"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="bundled-expat"
RDEPEND=">=dev-haskell/list-0.4.2:=[profile?] <dev-haskell/list-0.7:=[profile?]
>=dev-haskell/text-0.5.0.0:=[profile?] <dev-haskell/text-1.3.0.0:=[profile?]
>=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
- >=dev-lang/ghc-7.8.2:=
- !bundled-expat? ( dev-libs/expat )
+ >=dev-lang/ghc-8.4.3:=
+ dev-libs/expat
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
+ >=dev-haskell/cabal-2.2.0.1
"
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag bundled-expat bundle)
+ --flag=-bundle
}