summaryrefslogtreecommitdiff
path: root/dev-haskell/haskeline/haskeline-0.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/haskeline/haskeline-0.8.2.ebuild')
-rw-r--r--dev-haskell/haskeline/haskeline-0.8.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/haskeline/haskeline-0.8.2.ebuild b/dev-haskell/haskeline/haskeline-0.8.2.ebuild
new file mode 100644
index 000000000000..68052da08d5f
--- /dev/null
+++ b/dev-haskell/haskeline/haskeline-0.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+#hackport: flags: -examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A command-line interface for user input, written in Haskell"
+HOMEPAGE="https://github.com/judah/haskeline"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.10.6
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+terminfo"
+
+RESTRICT=test # test requires example executable which does not work correctly
+
+RDEPEND=">=dev-haskell/exceptions-0.10:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/stm-2.4:=[profile?] <dev-haskell/stm-2.6:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ terminfo? ( >=dev-haskell/terminfo-0.3.1.3:=[profile?] <dev-haskell/terminfo-0.5:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-examples \
+ $(cabal_flag terminfo terminfo)
+}
+
+# ghc-9.0.1 actually comes bundled with haskeline-0.8.1.0
+CABAL_CORE_LIB_GHC_PV="PM:8.10.6 PM:8.10.7 PM:9.0.1-r1 PM:9.0.2 PM:9999"