summaryrefslogtreecommitdiff
path: root/dev-haskell/gtk2hs-buildtools/gtk2hs-buildtools-0.13.8.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/gtk2hs-buildtools/gtk2hs-buildtools-0.13.8.0-r1.ebuild')
-rw-r--r--dev-haskell/gtk2hs-buildtools/gtk2hs-buildtools-0.13.8.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/gtk2hs-buildtools/gtk2hs-buildtools-0.13.8.0-r1.ebuild b/dev-haskell/gtk2hs-buildtools/gtk2hs-buildtools-0.13.8.0-r1.ebuild
new file mode 100644
index 000000000000..30ffca890e99
--- /dev/null
+++ b/dev-haskell/gtk2hs-buildtools/gtk2hs-buildtools-0.13.8.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Tools to build the Gtk2Hs suite of User Interface libraries"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+closuresignals"
+
+RDEPEND=">=dev-haskell/cabal-1.24.0.0:=[profile?]
+ dev-haskell/fail:=[profile?]
+ dev-haskell/hashtables:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.18.1.3
+ dev-haskell/happy
+"
+
+PATCHES=("${FILESDIR}"/${PN}-0.13.8.0-gcc-11.patch)
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag closuresignals closuresignals)
+}