summaryrefslogtreecommitdiff
path: root/dev-haskell/gluraw/gluraw-1.4.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/gluraw/gluraw-1.4.0.1.ebuild')
-rw-r--r--dev-haskell/gluraw/gluraw-1.4.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/gluraw/gluraw-1.4.0.1.ebuild b/dev-haskell/gluraw/gluraw-1.4.0.1.ebuild
new file mode 100644
index 000000000000..e20de22f180a
--- /dev/null
+++ b/dev-haskell/gluraw/gluraw-1.4.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+#hackport: flags: -usenativewindowslibraries
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="GLURaw"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A raw binding for the OpenGL graphics system"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/openglraw-1.3.0.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ virtual/glu
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-usenativewindowslibraries
+}