summaryrefslogtreecommitdiff
path: root/dev-haskell/git-lfs/git-lfs-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/git-lfs/git-lfs-1.2.0.ebuild')
-rw-r--r--dev-haskell/git-lfs/git-lfs-1.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-haskell/git-lfs/git-lfs-1.2.0.ebuild b/dev-haskell/git-lfs/git-lfs-1.2.0.ebuild
new file mode 100644
index 000000000000..2ab66ee62505
--- /dev/null
+++ b/dev-haskell/git-lfs/git-lfs-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="git-lfs protocol"
+HOMEPAGE="https://hackage.haskell.org/package/git-lfs"
+
+LICENSE="AGPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/aeson-1.3:=[profile?] <dev-haskell/aeson-2.1:=[profile?]
+ >=dev-haskell/case-insensitive-1.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/http-client-0.5:=[profile?] <dev-haskell/http-client-0.8:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?] <dev-haskell/http-types-0.13:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.8:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"