summaryrefslogtreecommitdiff
path: root/dev-haskell/esqueleto
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/esqueleto')
-rw-r--r--dev-haskell/esqueleto/Manifest3
-rw-r--r--dev-haskell/esqueleto/esqueleto-3.3.4.0.ebuild56
-rw-r--r--dev-haskell/esqueleto/metadata.xml44
3 files changed, 0 insertions, 103 deletions
diff --git a/dev-haskell/esqueleto/Manifest b/dev-haskell/esqueleto/Manifest
deleted file mode 100644
index 8e90cb263156..000000000000
--- a/dev-haskell/esqueleto/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST esqueleto-3.3.4.0.tar.gz 91243 BLAKE2B cf2741a6b4887216072985ebd9752a5e1380607d912ca98da018f530aa74863c62a9d6d5ba311ca156cc4aa06c10250e693807121c2a279433e9063085e4bdc9 SHA512 e120c656bf7b6029cf4833cfbeadab516dcd66bb4c27cf834a95a53f333193095c6e9921b2b230608aa052fd6b181a0ae2bd371575509b0bb269d8bd239dbfd2
-EBUILD esqueleto-3.3.4.0.ebuild 1682 BLAKE2B 5f9ac70fc9fc903171320172e0bbac8309ef467fa9b897725774437869fa37d12639bed0638ac462760cbe88165e94d1d7848e43b91e3fa31af7cf7a8c96cc2a SHA512 97a013dac86b3d375dd3ab9656120167c52c0010169cc406233ad81f44efd49203c979896dd37631ec3460f3083909de29df4f4e9ad0265226383cd50058a5b2
-MISC metadata.xml 2044 BLAKE2B cd50164a45e5280eaac47ab312a65ed74842b51c217efa7dfc02b327b6df2368a16114c214cec7239ef64e03e59b44d782aefb672bf7225ede69510221aaf6a7 SHA512 1fda178c8ed16085f85b8344036236fb095953f37e0e51f17cca33ed3783bc5f48760c262b44620ab049afdc5816b4ad8cc5c6cedbd7b06c1159d3810a880038
diff --git a/dev-haskell/esqueleto/esqueleto-3.3.4.0.ebuild b/dev-haskell/esqueleto/esqueleto-3.3.4.0.ebuild
deleted file mode 100644
index 72c7e224d40c..000000000000
--- a/dev-haskell/esqueleto/esqueleto-3.3.4.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.6.9999
-#hackport: flags: -mysql,-postgresql
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Type-safe EDSL for SQL queries on persistent backends"
-HOMEPAGE="https://github.com/bitemyapp/esqueleto"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RESTRICT=test # tries to access network
-
-RDEPEND=">=dev-haskell/aeson-1.0:=[profile?]
- >=dev-haskell/attoparsec-0.13:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
- dev-haskell/blaze-html:=[profile?]
- >=dev-haskell/conduit-1.3:=[profile?]
- dev-haskell/monad-logger:=[profile?]
- >=dev-haskell/persistent-2.10.0:=[profile?] <dev-haskell/persistent-2.11:=[profile?]
- >=dev-haskell/resourcet-1.2:=[profile?]
- >=dev-haskell/tagged-0.2:=[profile?]
- >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
- dev-haskell/unliftio:=[profile?]
- >=dev-haskell/unordered-containers-0.2:=[profile?]
- >=dev-lang/ghc-7.10.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.22.2.0
- test? ( dev-haskell/exceptions
- dev-haskell/hspec
- dev-haskell/mtl
- dev-haskell/mysql
- dev-haskell/mysql-simple
- dev-haskell/persistent-mysql
- >=dev-haskell/persistent-postgresql-2.10.0 <dev-haskell/persistent-postgresql-2.11
- dev-haskell/persistent-sqlite
- dev-haskell/persistent-template
- dev-haskell/postgresql-libpq
- dev-haskell/postgresql-simple
- dev-haskell/vector )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-mysql \
- --flag=-postgresql
-}
diff --git a/dev-haskell/esqueleto/metadata.xml b/dev-haskell/esqueleto/metadata.xml
deleted file mode 100644
index 7e335b4c5bb0..000000000000
--- a/dev-haskell/esqueleto/metadata.xml
+++ /dev/null
@@ -1,44 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- @persistent@ is a library for type-safe data serialization. It
- has many kinds of backends, such as SQL backends
- (@persistent-mysql@, @persistent-postgresql@,
- @persistent-sqlite@) and NoSQL backends (@persistent-mongoDB@).
-
- While @persistent@ is a nice library for storing and retrieving
- records, currently it has a poor interface for SQL backends
- compared to SQL itself. For example, it's extremely hard to do
- a type-safe @JOIN@ on a many-to-one relation, and simply
- impossible to do any other kinds of @JOIN@s (including for the
- very common many-to-many relations). Users have the option of
- writing raw SQL, but that's error prone and not type-checked.
-
- @esqueleto@ is a bare bones, type-safe EDSL for SQL queries
- that works with unmodified @persistent@ SQL backends. Its
- language closely resembles SQL, so (a) you don't have to learn
- new concepts, just new syntax, and (b) it's fairly easy to
- predict the generated SQL and optimize it for your backend.
- Most kinds of errors committed when writing SQL are caught as
- compile-time errors---although it is possible to write
- type-checked @esqueleto@ queries that fail at runtime.
-
- Currently only @SELECT@s are supported. Not all SQL features
- are available, but most of them can be easily added (especially
- functions), so please open an issue or send a pull request if
- you need anything that is not covered by @esqueleto@ on
- &lt;https://github.com/meteficha/esqueleto/&gt;.
-
- The name of this library means \"skeleton\" in Portuguese and
- contains all three SQL letters in the correct order =). It was
- inspired by Scala's Squeryl but created from scratch.
- </longdescription>
- <upstream>
- <remote-id type="github">prowdsponsor/esqueleto</remote-id>
- </upstream>
-</pkgmetadata>