summaryrefslogtreecommitdiff
path: root/dev-haskell/entropy/entropy-0.4.1.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/entropy/entropy-0.4.1.6-r1.ebuild')
-rw-r--r--dev-haskell/entropy/entropy-0.4.1.6-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/entropy/entropy-0.4.1.6-r1.ebuild b/dev-haskell/entropy/entropy-0.4.1.6-r1.ebuild
new file mode 100644
index 000000000000..04b1100f2a3b
--- /dev/null
+++ b/dev-haskell/entropy/entropy-0.4.1.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A platform independent entropy source"
+HOMEPAGE="https://github.com/TomMD/entropy"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="halvm"
+
+RDEPEND=">=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'Cabal >= 1.10 && < 3.3' 'Cabal >= 1.10'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag halvm halvm)
+}