summaryrefslogtreecommitdiff
path: root/dev-haskell/encoding/encoding-0.8.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/encoding/encoding-0.8.5.ebuild')
-rw-r--r--dev-haskell/encoding/encoding-0.8.5.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-haskell/encoding/encoding-0.8.5.ebuild b/dev-haskell/encoding/encoding-0.8.5.ebuild
deleted file mode 100644
index 48de713accc6..000000000000
--- a/dev-haskell/encoding/encoding-0.8.5.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="A library for various character encodings"
-HOMEPAGE="http://code.haskell.org/encoding/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+systemencoding"
-
-RDEPEND=">=dev-haskell/extensible-exceptions-0.1:=[profile?] <dev-haskell/extensible-exceptions-0.2:=[profile?]
- >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
- >=dev-haskell/regex-compat-0.71:=[profile?]
- >=dev-lang/ghc-7.8.2:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.0
- >=dev-haskell/haxml-1.22 <dev-haskell/haxml-1.26
- test? ( dev-haskell/hunit
- dev-haskell/quickcheck )
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-0.8.2-overflow.patch
-)
-
-src_prepare() {
- default
-
- cabal_chdeps \
- 'regex-compat >=0.71 && <0.95' 'regex-compat >=0.71' \
- 'containers >=0.4 && <0.6' 'containers >=0.4 && <0.7'
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag systemencoding systemencoding)
-}