summaryrefslogtreecommitdiff
path: root/dev-haskell/dlist/dlist-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/dlist/dlist-1.0.ebuild')
-rw-r--r--dev-haskell/dlist/dlist-1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/dlist/dlist-1.0.ebuild b/dev-haskell/dlist/dlist-1.0.ebuild
new file mode 100644
index 000000000000..15daed49f8ee
--- /dev/null
+++ b/dev-haskell/dlist/dlist-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Difference lists"
+HOMEPAGE="https://github.com/spl/dlist"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="werror"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.10 <dev-haskell/quickcheck-2.15 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag werror werror)
+}