summaryrefslogtreecommitdiff
path: root/dev-haskell/dictionary-sharing/dictionary-sharing-0.1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/dictionary-sharing/dictionary-sharing-0.1.0.0.ebuild')
-rw-r--r--dev-haskell/dictionary-sharing/dictionary-sharing-0.1.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/dictionary-sharing/dictionary-sharing-0.1.0.0.ebuild b/dev-haskell/dictionary-sharing/dictionary-sharing-0.1.0.0.ebuild
new file mode 100644
index 000000000000..925356c70df5
--- /dev/null
+++ b/dev-haskell/dictionary-sharing/dictionary-sharing-0.1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Sharing/memoization of class members"
+HOMEPAGE="https://hackage.haskell.org/package/dictionary-sharing"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+src_prepare() {
+ default
+
+ #https://hackage.haskell.org/package/dictionary-sharing-0.1.0.0/revisions/
+ cabal_chdeps \
+ 'containers >=0.5 && <0.6' 'containers >= 0.5'
+}