summaryrefslogtreecommitdiff
path: root/dev-haskell/crypto-api/crypto-api-0.13.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/crypto-api/crypto-api-0.13.3.ebuild')
-rw-r--r--dev-haskell/crypto-api/crypto-api-0.13.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-haskell/crypto-api/crypto-api-0.13.3.ebuild b/dev-haskell/crypto-api/crypto-api-0.13.3.ebuild
new file mode 100644
index 000000000000..4b61011d2c68
--- /dev/null
+++ b/dev-haskell/crypto-api/crypto-api-0.13.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A generic interface for cryptographic operations"
+HOMEPAGE="https://github.com/TomMD/crypto-api"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="all-cpolys"
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ dev-haskell/entropy:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag all-cpolys all_cpolys)
+}