summaryrefslogtreecommitdiff
path: root/dev-haskell/comonad/comonad-5.0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/comonad/comonad-5.0.8.ebuild')
-rw-r--r--dev-haskell/comonad/comonad-5.0.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/comonad/comonad-5.0.8.ebuild b/dev-haskell/comonad/comonad-5.0.8.ebuild
new file mode 100644
index 000000000000..8052255f0991
--- /dev/null
+++ b/dev-haskell/comonad/comonad-5.0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+#hackport: flags: +distributive,+containers,test-doctests:test
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="The Comonads package authored by Edward Kmett"
+HOMEPAGE="https://github.com/ekmett/comonad/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+indexed-traversable"
+
+RDEPEND=">=dev-haskell/distributive-0.5.2:=[profile?] <dev-haskell/distributive-1:=[profile?]
+ >=dev-haskell/semigroups-0.18.5:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/tagged-0.8.6.1:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/transformers-compat-0.5:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ indexed-traversable? ( >=dev-haskell/indexed-traversable-0.1.1:=[profile?] <dev-haskell/indexed-traversable-0.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=containers \
+ --flag=distributive \
+ $(cabal_flag indexed-traversable indexed-traversable)
+}