summaryrefslogtreecommitdiff
path: root/dev-haskell/bloomfilter/bloomfilter-2.0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/bloomfilter/bloomfilter-2.0.1.0.ebuild')
-rw-r--r--dev-haskell/bloomfilter/bloomfilter-2.0.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-haskell/bloomfilter/bloomfilter-2.0.1.0.ebuild b/dev-haskell/bloomfilter/bloomfilter-2.0.1.0.ebuild
new file mode 100644
index 000000000000..9b1acb05d209
--- /dev/null
+++ b/dev-haskell/bloomfilter/bloomfilter-2.0.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Pure and impure Bloom Filter implementations"
+HOMEPAGE="https://github.com/bos/bloomfilter"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.5
+ dev-haskell/random
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2 )
+"