summaryrefslogtreecommitdiff
path: root/dev-haskell/biosff/biosff-0.3.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/biosff/biosff-0.3.7.1.ebuild')
-rw-r--r--dev-haskell/biosff/biosff-0.3.7.1.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/dev-haskell/biosff/biosff-0.3.7.1.ebuild b/dev-haskell/biosff/biosff-0.3.7.1.ebuild
index 4ca013c51520..a3d46f863ec0 100644
--- a/dev-haskell/biosff/biosff-0.3.7.1.ebuild
+++ b/dev-haskell/biosff/biosff-0.3.7.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.3.4.9999
+# ebuild generated by hackport 0.6.6.9999
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Library and executables for working with SFF files"
@@ -17,19 +17,16 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+fclip +flower +frecover"
-RDEPEND="dev-haskell/binary:=[profile?]
- >=dev-haskell/biocore-0.3:=[profile?]
- dev-haskell/cmdargs:=[profile?]
- >=dev-haskell/mtl-2:=[profile?]
+RDEPEND=">=dev-haskell/biocore-0.3:=[profile?]
>=dev-lang/ghc-7.4.1:=
+ flower? ( dev-haskell/cmdargs:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ghc-7.10.patch
-}
+PATCHES=("${FILESDIR}"/${P}-ghc-7.10.patch)
src_configure() {
haskell-cabal_src_configure \