summaryrefslogtreecommitdiff
path: root/dev-haskell/binary/binary-0.8.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/binary/binary-0.8.8.0.ebuild')
-rw-r--r--dev-haskell/binary/binary-0.8.8.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/binary/binary-0.8.8.0.ebuild b/dev-haskell/binary/binary-0.8.8.0.ebuild
new file mode 100644
index 000000000000..dae0bfaf3187
--- /dev/null
+++ b/dev-haskell/binary/binary-0.8.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Circular depend: test-suite"
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binary serialisation for Haskell values using lazy ByteStrings"
+HOMEPAGE="https://github.com/kolmodin/binary"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.10
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT=test # circular depend: test-framework->base-orphans->cabal->semigroups->nats->binary
+
+RDEPEND=">=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+"
+
+CABAL_CORE_LIB_GHC_PV="PM:8.10.5-r1 PM:8.10.6 PM:8.10.7 PM:9.0.1-r1 PM:9.0.2 PM:9999"