summaryrefslogtreecommitdiff
path: root/dev-haskell/attoparsec/attoparsec-0.13.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/attoparsec/attoparsec-0.13.2.3.ebuild')
-rw-r--r--dev-haskell/attoparsec/attoparsec-0.13.2.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/attoparsec/attoparsec-0.13.2.3.ebuild b/dev-haskell/attoparsec/attoparsec-0.13.2.3.ebuild
new file mode 100644
index 000000000000..20e44cf82d48
--- /dev/null
+++ b/dev-haskell/attoparsec/attoparsec-0.13.2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Disable test-suite: circular depends
+inherit haskell-cabal
+
+DESCRIPTION="Fast combinator parsing for bytestrings and text"
+HOMEPAGE="https://github.com/bos/attoparsec"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # QC-2.10 finds contradiction
+
+RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
+ >=dev-haskell/scientific-0.3.1:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semigroups-0.16.1:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ >=dev-haskell/text-1.1.1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}