summaryrefslogtreecommitdiff
path: root/dev-haskell/attoparsec/attoparsec-0.13.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/attoparsec/attoparsec-0.13.0.2.ebuild')
-rw-r--r--dev-haskell/attoparsec/attoparsec-0.13.0.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/attoparsec/attoparsec-0.13.0.2.ebuild b/dev-haskell/attoparsec/attoparsec-0.13.0.2.ebuild
new file mode 100644
index 000000000000..3c1fe089edd7
--- /dev/null
+++ b/dev-haskell/attoparsec/attoparsec-0.13.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.7.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast combinator parsing for bytestrings and text"
+HOMEPAGE="https://github.com/bos/attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/scientific-0.3.1:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/text-1.1.1.3:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.7
+ dev-haskell/quickcheck-unicode
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-quickcheck-0.8
+ dev-haskell/vector )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}