summaryrefslogtreecommitdiff
path: root/dev-haskell/asn1-data
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/asn1-data')
-rw-r--r--dev-haskell/asn1-data/Manifest7
-rw-r--r--dev-haskell/asn1-data/asn1-data-0.7.1-r1.ebuild31
-rw-r--r--dev-haskell/asn1-data/asn1-data-0.7.1.ebuild25
-rw-r--r--dev-haskell/asn1-data/asn1-data-0.7.2.ebuild33
-rw-r--r--dev-haskell/asn1-data/files/asn1-data-0.7.1-ghc-7.10.patch16
-rw-r--r--dev-haskell/asn1-data/metadata.xml16
6 files changed, 128 insertions, 0 deletions
diff --git a/dev-haskell/asn1-data/Manifest b/dev-haskell/asn1-data/Manifest
new file mode 100644
index 000000000000..8c7c77792ed1
--- /dev/null
+++ b/dev-haskell/asn1-data/Manifest
@@ -0,0 +1,7 @@
+AUX asn1-data-0.7.1-ghc-7.10.patch 694 BLAKE2B 5c74f73562b63f78ea2aca0cbf3c01cc6a9a64624c7088404be40e4f1ba6bebed95e852b7dfa2f7b222f84a189a550013f11a1d6a44d983ac0d29155e2848d57 SHA512 272069aee6905a2233ee929024cb919edd3c62771a90b31194b458fb9c514a23f3038055c2122230c556ec1aa6e53f5e8b41d81734ce05e7f6b9cd90279e735f
+DIST asn1-data-0.7.1.tar.gz 17500 BLAKE2B 4c24167096019d7834c8ebb6fe3d36b41ac366042ea69aa7e0fbc745af7d05bf204e15d4137f2b57ef2f30f5c2cd4905859cf6deedda4966412a23a3c2bcac90 SHA512 dc6021daf15e5f9b93703641780c6d81c6b385d2127bcc2f735ecaf54d1be5163ad5e9ae291a3e223ff05cf03e8bbf11af0791ee810a0ba174e9cc9e9fd910d0
+DIST asn1-data-0.7.2.tar.gz 17672 BLAKE2B a4d088400c58efe6528f49eb728f5be902f91fe8de32391e1267ec5ba596c51095df91444b41577d52554778e4589121c9d65243f0fb744277ce933729b062fa SHA512 739c2a9e99a978ba5384da5d5ed388554471f2f6e898c9e07f26de6c6d48bbb236d83b6e2281be7ce4d9db6225acb230010393e1cd368ef9cf4f65eddb8e1e38
+EBUILD asn1-data-0.7.1-r1.ebuild 748 BLAKE2B d97169a49d7be4635495176500f4b1fa116f0f02d2bf83b8101a8fe497dc1e75d062982bcda75ee01ed260e2e962f459f5e7d9bb7dc9781e5199965f83b5b4c7 SHA512 76864a172b5a7b9e18e99fb254617e89f45eeccfa910d8fef0a8e38c4bb702eb018d61bb987baf2fbbe197226bc0cd4cfa24eba25aed5d0fc731739377c98771
+EBUILD asn1-data-0.7.1.ebuild 667 BLAKE2B 6be26bc84a6436219abce4e0b3b7fa29c6d909039190bec4cfae03873c30fa68e3e3fcefd22c26438c69bf95220d355caf4d4dd36ae2460b0c666c1e1bc9cf35 SHA512 e3e95898cad9560cc77c71293b14e63e09b37496ecb14e3b61fb680ed92813e79a7b2fc9facbec1d42bd13cc917a6e2402a833995692665b335264e3be4c5fd1
+EBUILD asn1-data-0.7.2.ebuild 773 BLAKE2B 0e812de5bc309e4bddefca90db0cead63acbe1c6c26c21bad48a5c6e50fdca0cdafd22d8f22b1477b9278f18b245635b5c907c3a615d8ebc4b5d6e3649a30c9e SHA512 9e10be2df0490243724d3674401dfca75abde4e6245bf20e41feabb32c6f65b1fd503125a67c9d2acba7550347267f9e7318539e8bd0970ed70ba0fb5cb39a15
+MISC metadata.xml 530 BLAKE2B 51cf206d4c4e31306e91d0c6376add5ec793ad5f59df2bf8b7f8513e3801e442ea3a846945f5e715271f49c14e6833f739cd93999fb5f920f6b4cc808c888e90 SHA512 b3d4af593f4fcbee0cae32b9cda14786e111cfcb043721b666005a710b72804acd528123f4a90e5222dc985a9475633c5ee1b5f6106cc49b3206347c438e4574
diff --git a/dev-haskell/asn1-data/asn1-data-0.7.1-r1.ebuild b/dev-haskell/asn1-data/asn1-data-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..533e1e7cdeb2
--- /dev/null
+++ b/dev-haskell/asn1-data/asn1-data-0.7.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="ASN1 data reader and writer in RAW, BER and DER forms"
+HOMEPAGE="https://github.com/vincenthz/hs-asn1/tree/master/data"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+}
diff --git a/dev-haskell/asn1-data/asn1-data-0.7.1.ebuild b/dev-haskell/asn1-data/asn1-data-0.7.1.ebuild
new file mode 100644
index 000000000000..72b24d566c85
--- /dev/null
+++ b/dev-haskell/asn1-data/asn1-data-0.7.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="ASN1 data reader and writer in RAW, BER and DER forms"
+HOMEPAGE="https://github.com/vincenthz/hs-asn1/tree/master/data"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal[profile?]
+ dev-haskell/mtl[profile?]
+ >=dev-haskell/text-0.11[profile?]
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/asn1-data/asn1-data-0.7.2.ebuild b/dev-haskell/asn1-data/asn1-data-0.7.2.ebuild
new file mode 100644
index 000000000000..c978ebce58ff
--- /dev/null
+++ b/dev-haskell/asn1-data/asn1-data-0.7.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -test
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="ASN1 data reader and writer in RAW, BER and DER forms"
+HOMEPAGE="https://github.com/vincenthz/hs-asn1/tree/master/data"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-test
+}
diff --git a/dev-haskell/asn1-data/files/asn1-data-0.7.1-ghc-7.10.patch b/dev-haskell/asn1-data/files/asn1-data-0.7.1-ghc-7.10.patch
new file mode 100644
index 000000000000..8bf958454bef
--- /dev/null
+++ b/dev-haskell/asn1-data/files/asn1-data-0.7.1-ghc-7.10.patch
@@ -0,0 +1,16 @@
+diff --git a/Data/ASN1/Parse.hs b/Data/ASN1/Parse.hs
+index eeea2be..83bc80e 100644
+--- a/Data/ASN1/Parse.hs
++++ b/Data/ASN1/Parse.hs
+@@ -24 +24 @@ import Control.Monad.Error
+-import Control.Applicative ((<$>))
++import Control.Applicative ((<$>), Applicative)
+@@ -25,7 +25,7 @@ import Control.Applicative ((<$>))
+
+ -- | Parse ASN1 Monad
+ newtype ParseASN1 a = P { runP :: ErrorT String (State [ASN1]) a }
+- deriving (Functor, Monad, MonadError String)
++ deriving (Functor, Applicative, Monad, MonadError String)
+
+ -- | run the parse monad over a stream and returns the result and the remaining ASN1 Stream.
+ runParseASN1State :: ParseASN1 a -> [ASN1] -> Either String (a,[ASN1])
diff --git a/dev-haskell/asn1-data/metadata.xml b/dev-haskell/asn1-data/metadata.xml
new file mode 100644
index 000000000000..03e145ac586e
--- /dev/null
+++ b/dev-haskell/asn1-data/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ ASN1 data reader and writer in raw form with supports for high level forms of ASN1 (BER, CER and DER).
+
+ All interfaces use the enumerator interface.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-asn1-data</remote-id>
+ </upstream>
+</pkgmetadata>