summaryrefslogtreecommitdiff
path: root/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.9.ebuild')
-rw-r--r--dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.9.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.9.ebuild b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.9.ebuild
new file mode 100644
index 000000000000..dcebf67d8c3d
--- /dev/null
+++ b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: example:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_HACKAGE_REVISION="3"
+inherit haskell-cabal
+
+CABAL_FILE="${S}/${PN}.cabal"
+CABAL_DISTFILE="${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
+
+DESCRIPTION="The Wadler/Leijen Pretty Printer for colored ANSI terminal output"
+HOMEPAGE="https://github.com/ekmett/ansi-wl-pprint"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
+ -> ${CABAL_DISTFILE}"
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.9.1:=[profile?] <dev-haskell/ansi-terminal-0.12:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${CABAL_DISTFILE}" "${CABAL_FILE}" || die
+
+ # Convert to unix line endings
+ dos2unix "${CABAL_FILE}" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples example)
+}