summaryrefslogtreecommitdiff
path: root/dev-haskell/aeson-diff/aeson-diff-1.1.0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/aeson-diff/aeson-diff-1.1.0.9.ebuild')
-rw-r--r--dev-haskell/aeson-diff/aeson-diff-1.1.0.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/aeson-diff/aeson-diff-1.1.0.9.ebuild b/dev-haskell/aeson-diff/aeson-diff-1.1.0.9.ebuild
new file mode 100644
index 000000000000..1d4b1fc48bed
--- /dev/null
+++ b/dev-haskell/aeson-diff/aeson-diff-1.1.0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extract and apply patches to JSON documents"
+HOMEPAGE="https://github.com/thsutton/aeson-diff"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Ambiguous module name ‘Data.Vector’: found in multiple packages: AC-Vector-Fancy-2.4.0 vector-0.12.0.2
+RESTRICT=test
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/edit-distance-vector:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( >=dev-haskell/doctest-0.9
+ dev-haskell/glob
+ dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
+
+src_prepare() {
+ default
+ cabal_chdeps \
+ 'base >=4.9 && <4.15' 'base >=4.9'
+}