summaryrefslogtreecommitdiff
path: root/dev-go/act/act-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/act/act-1.6.0.ebuild')
-rw-r--r--dev-go/act/act-1.6.0.ebuild39
1 files changed, 6 insertions, 33 deletions
diff --git a/dev-go/act/act-1.6.0.ebuild b/dev-go/act/act-1.6.0.ebuild
index 3a2dd997297d..4baa06a089d0 100644
--- a/dev-go/act/act-1.6.0.ebuild
+++ b/dev-go/act/act-1.6.0.ebuild
@@ -3,8 +3,6 @@
EAPI=8
-inherit go-module toolchain-funcs
-
DESCRIPTION="Automated Component Toolkit code generator"
HOMEPAGE="https://github.com/Autodesk/AutomaticComponentToolkit"
SRC_URI="https://github.com/Autodesk/AutomaticComponentToolkit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -14,44 +12,19 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
-RESTRICT="test"
-
-# Package does not follow the usual go directory structure
-# Functions borrowed from dev-lang/go ebuild.
-go_arch() {
- # By chance most portage arch names match Go
- local portage_arch=$(tc-arch $@)
- case "${portage_arch}" in
- x86) echo 386;;
- x64-*) echo amd64;;
- *) echo "${portage_arch}";;
- esac
-}
+RESTRICT="strip test"
-go_arm() {
- case "${1:-${CHOST}}" in
- armv5*) echo 5;;
- armv6*) echo 6;;
- armv7*) echo 7;;
- *)
- die "unknown GOARM for ${1:-${CHOST}}"
- ;;
- esac
-}
+BDEPEND="dev-lang/go"
-src_compile() {
- export GOARCH=$(go_arch)
- export GOOS=linux
- if [[ ${ARCH} == arm ]]; then
- export GOARM=$(go_arm)
- fi
+QA_FLAGS_IGNORED="usr/bin/act"
- cd "${S}"/Source || die
+src_compile() {
+ cd Source || die
go build -x -o ../${PN} *.go || die
}
src_install() {
- newbin "${S}"/${PN} ${PN}
+ dobin ${PN}
einstalldocs
dodoc -r Documentation/.
}