summaryrefslogtreecommitdiff
path: root/dev-gap/tomlib
diff options
context:
space:
mode:
Diffstat (limited to 'dev-gap/tomlib')
-rw-r--r--dev-gap/tomlib/Manifest3
-rw-r--r--dev-gap/tomlib/metadata.xml43
-rw-r--r--dev-gap/tomlib/tomlib-1.2.9.ebuild22
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-gap/tomlib/Manifest b/dev-gap/tomlib/Manifest
new file mode 100644
index 000000000000..5aa1526f0b39
--- /dev/null
+++ b/dev-gap/tomlib/Manifest
@@ -0,0 +1,3 @@
+DIST tomlib-1.2.9.tar.gz 53258295 BLAKE2B 67c569c0ac041ebbe2c0a1d47ada85685e01e5acfed7739d22e57f773c7c56d850bc7474c589ec9b50e78c6c2f94777252a0791c2fad0157998375863116b37d SHA512 01c1d451600c6d598a5400f9c7cb3cfce056907842a95ccbef09a149d10762068fd03931b5b0ed677ee2fdc52e4be9ac4e81bf17f2b3c104cb50c4987df30cbc
+EBUILD tomlib-1.2.9.ebuild 534 BLAKE2B 37414c793fc9bb020560a2fece266de1f9a565c0fca4dda8a39a6608bcb7343fb17c201dcaaa0d5fca55f4f863789df9e85c637ae7b8a4d9eab6018220ab0a83 SHA512 9be0ee709bde20aa793bbb4bcd3d445df72cbc5ca6f8d9eab5b349e792c21333985fb2f97efdfd59568a8ca537d9312892b4bfd21ee9758600e97dff3b6dcc23
+MISC metadata.xml 1863 BLAKE2B c9edeb2905cf27b4d0d60cdbce265f3d5813ac8678a9f890ce760883c7fc55a1825d6ed4984c10d49328800b72cc48c996532298cc1638f229a8d21b90c2ec63 SHA512 608e1f073d67954803e523f128daa136843fb24af50561a3c8920aec4cdc7de3ad62b34917b172e258ffad98131e9062ca2228dcab1a5d22322ae9ca78c5f214
diff --git a/dev-gap/tomlib/metadata.xml b/dev-gap/tomlib/metadata.xml
new file mode 100644
index 000000000000..9ed3999e9ec1
--- /dev/null
+++ b/dev-gap/tomlib/metadata.xml
@@ -0,0 +1,43 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The concept of a table of marks was introduced by W. Burnside in his
+ 1955 book Theory of Groups of Finite Order. Therefore a table of
+ marks is sometimes called a Burnside matrix.
+
+ The table of marks of a finite group G is a matrix whose rows and
+ columns are labelled by the conjugacy classes of subgroups of G and
+ where for two subgroups H and K the (H, K)-entry is the number of
+ fixed points of K in the transitive action of G on the cosets of H
+ in G. So the table of marks characterizes the set of all permutation
+ representations of G. Moreover, the table of marks gives a compact
+ description of the subgroup lattice of G, since from the numbers of
+ fixed points the numbers of conjugates of a subgroup K contained in
+ a subgroup H can be derived.
+
+ For small groups the table of marks of G can be constructed directly
+ in GAP by first computing the entire subgroup lattice of G. However,
+ for larger groups this method is unfeasible. The GAP Table of Marks
+ library provides access to several hundred tables of marks and their
+ maximal subgroups.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/tomlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-gap/tomlib/tomlib-1.2.9.ebuild b/dev-gap/tomlib/tomlib-1.2.9.ebuild
new file mode 100644
index 000000000000..f7a18f9624df
--- /dev/null
+++ b/dev-gap/tomlib/tomlib-1.2.9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="The GAP library of Tables of Marks"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-gap/atlasrep"
+
+# The are "extra" docs and not the HTML produced by GAPDoc. The glob
+# gets expanded if we use a plain variable but not if we use a bash
+# array.
+HTML_DOCS="htm/*"
+
+GAP_PKG_EXTRA_INSTALL=( data )