summaryrefslogtreecommitdiff
path: root/dev-gap/sonata
diff options
context:
space:
mode:
Diffstat (limited to 'dev-gap/sonata')
-rw-r--r--dev-gap/sonata/Manifest3
-rw-r--r--dev-gap/sonata/metadata.xml52
-rw-r--r--dev-gap/sonata/sonata-2.9.6.ebuild16
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-gap/sonata/Manifest b/dev-gap/sonata/Manifest
new file mode 100644
index 000000000000..c2f79b36e677
--- /dev/null
+++ b/dev-gap/sonata/Manifest
@@ -0,0 +1,3 @@
+DIST sonata-2.9.6.tar.gz 1685036 BLAKE2B 3aeebfb1bca10b49e09220db0b33d1454b9536825030b027ecf8ba35645d764234b43adacd7e3ada8c4aaea25d6f19ca39672546e4e9347950ca0c310f23a7ed SHA512 fda8c4c2b9f22c971edc23fee8f47bc49973bf3864ce5ba29839566c1cd9e4c859323222e83303c86cb23c7139c931d8a087fab9fd6c6875519f1a087626cdcb
+EBUILD sonata-2.9.6.ebuild 383 BLAKE2B 9b479908bd5f9f0d8314191d87b16e5f1b80320bf49d4301ed220c3bd1e78aa4e0fee0ec79f990d6b3cafeee154cefbf898d1c7d623db158b1354d2e092e38db SHA512 bfc5ed97296a12f71211a8d05085dd17834241e4372f761ba783beb219e2f782775cf52876332047ec48d873c15ff12343448b4fc772de062235173542be03ce
+MISC metadata.xml 2030 BLAKE2B d678b875000d1226c0950c091361548f554be5c9b7db5e83077a7943f78e23776ee153bdc78f195bd6b17ce5e1e4a5026f8d12fd1e5edcd4975a6c0129caedf4 SHA512 e1322909f797892ec63970e4bddbb51fc7fa32a7f98d8fc82e1e20e321df15cb068fbadb53bfbaa7bc3c55a89045cb66238be1e31af1fd8ba772450bc26fc062
diff --git a/dev-gap/sonata/metadata.xml b/dev-gap/sonata/metadata.xml
new file mode 100644
index 000000000000..45e966acb099
--- /dev/null
+++ b/dev-gap/sonata/metadata.xml
@@ -0,0 +1,52 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ SONATA stands for "systems of nearrings and their applications." It
+ provides methods for the construction and the analysis of finite
+ nearrings:
+
+ * Methods for constructing all endomorphisms and all
+ fixed-point-free automorphisms of a given group.
+
+ * Methods for constructing the following nearrings of functions on
+ a group G: the nearring of polynomial functions of G (in the sense
+ of Lausch-Nöbauer); the nearring of compatible functions of G;
+ distributively generated nearrings such as I(G), A(G), E(G);
+ centralizer nearrings.
+
+ * A library of all small nearrings (up to order 15) and all small
+ nearrings with identity (up to order 31).
+
+ * Functions to obtain solvable fixed-point-free automorphism
+ groups on abelian groups, nearfields, planar nearrings, as well
+ as designs from those.
+
+ * Various functions to study the structure (size, ideals,
+ N-groups, ...) of nearrings, to determine properties of nearring
+ elements, and to decide whether two nearrings are isomorphic.
+
+ * If the package XGAP is installed, the lattices of one- and
+ two-sided ideals of a nearring can be studied interactively using
+ a graphical representation
+
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/sonata</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-gap/sonata/sonata-2.9.6.ebuild b/dev-gap/sonata/sonata-2.9.6.ebuild
new file mode 100644
index 000000000000..b444b3fe3e9a
--- /dev/null
+++ b/dev-gap/sonata/sonata-2.9.6.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="System of finite nearrings and their applications"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+GAP_PKG_EXTRA_INSTALL=( grp nr nri )
+gap-pkg_enable_tests