summaryrefslogtreecommitdiff
path: root/dev-gap/smallgrp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-gap/smallgrp')
-rw-r--r--dev-gap/smallgrp/Manifest3
-rw-r--r--dev-gap/smallgrp/metadata.xml29
-rw-r--r--dev-gap/smallgrp/smallgrp-1.5.3.ebuild24
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-gap/smallgrp/Manifest b/dev-gap/smallgrp/Manifest
new file mode 100644
index 000000000000..02c4eb2a17a0
--- /dev/null
+++ b/dev-gap/smallgrp/Manifest
@@ -0,0 +1,3 @@
+DIST SmallGrp-1.5.3.tar.gz 20122081 BLAKE2B 91d016c153a189e0505ab52af8aa10f9f5eba90363c7e47258bc589caa5d0bb57faf2fcba99b0a804b3589fbc3a686a923debd68ab790689c7abe62bfbcb9f1a SHA512 4ba88df20ed71cddb2f72d7b9a74b2262aca318e15ce3232e73f7b995d6372caad23b1390030b64cc3a7fdbae5e215f0a20dcad98a2859197187096b01e5da88
+EBUILD smallgrp-1.5.3.ebuild 533 BLAKE2B 5a15cabbf76812f1ed0c541f563b8bd44ecd19df60efd5fef7cd1d2a6173fe623a8cdca6e8fbf289c0c3c99a77e9ba9ee65bd2ecd10e84fcf1ecd6920b907bf9 SHA512 3747605a9a493e8a9720920ef8d7c35388cef28375d6a6f4a60cb752403315560223819dcaef3d7f7fd4364c2b9d418e6059a36ec2412915f8c47d319eedd501
+MISC metadata.xml 1060 BLAKE2B cbb5f7e691dd8472ad86872c4653824e19afcbe135f98813892fd471417700d0dc0958c95dc9773a4e72a571124de95f3d3e48bc4e750de3c3129a2325983287 SHA512 40ed8cf5d765478d079f0c07f52ae69c981adb71437c8d26c67a8bfd6741eb40696e677121adb42c1bf95e0a100d30d7aceca1a189a72ef6bb243baf09c6c170
diff --git a/dev-gap/smallgrp/metadata.xml b/dev-gap/smallgrp/metadata.xml
new file mode 100644
index 000000000000..79280f03bc91
--- /dev/null
+++ b/dev-gap/smallgrp/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The SmallGrp package provides the library of groups of certain
+ "small" orders. The groups are sorted by their orders and they are
+ listed up to isomorphism; that is, for each of the available orders
+ a complete and irredundant list of isomorphism type representatives
+ of groups is given.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/smallgrp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-gap/smallgrp/smallgrp-1.5.3.ebuild b/dev-gap/smallgrp/smallgrp-1.5.3.ebuild
new file mode 100644
index 000000000000..4908c6c75b2e
--- /dev/null
+++ b/dev-gap/smallgrp/smallgrp-1.5.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+MY_P="SmallGrp-${PV}"
+DESCRIPTION="The GAP Small Groups Library"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/smallgrp/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Artistic-2"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-gap/gapdoc"
+gap-pkg_enable_tests
+
+src_install() {
+ # Define the variable here so globbing will work
+ GAP_PKG_EXTRA_INSTALL=( id* small* )
+ gap-pkg_src_install
+}