summaryrefslogtreecommitdiff
path: root/dev-gap/orb/orb-4.9.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-gap/orb/orb-4.9.0-r1.ebuild')
-rw-r--r--dev-gap/orb/orb-4.9.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-gap/orb/orb-4.9.0-r1.ebuild b/dev-gap/orb/orb-4.9.0-r1.ebuild
new file mode 100644
index 000000000000..4161922dd244
--- /dev/null
+++ b/dev-gap/orb/orb-4.9.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg toolchain-funcs
+
+DESCRIPTION="GAP methods to enumerate orbits"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="sci-mathematics/gap:="
+RDEPEND="${DEPEND}"
+BDEPEND="test? (
+ dev-gap/atlasrep
+ dev-gap/cvec
+ dev-gap/io
+)"
+
+gap-pkg_enable_tests
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_install() {
+ gap-pkg_src_install
+ use examples && dodoc -r examples
+}