summaryrefslogtreecommitdiff
path: root/dev-gap/gbnp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-gap/gbnp')
-rw-r--r--dev-gap/gbnp/Manifest3
-rw-r--r--dev-gap/gbnp/gbnp-1.0.5.ebuild28
-rw-r--r--dev-gap/gbnp/metadata.xml32
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-gap/gbnp/Manifest b/dev-gap/gbnp/Manifest
new file mode 100644
index 000000000000..cb409798fbf6
--- /dev/null
+++ b/dev-gap/gbnp/Manifest
@@ -0,0 +1,3 @@
+DIST gbnp-1.0.5.tar.gz 830298 BLAKE2B 785dcf648efa1c859aa5f07510366406b4e91c26b5c322b1909c510beb01b4428d2e3acf8a9415b7b2aef11f2861907b20d8f617fc55c799e9a0bb2aad8b7c5d SHA512 98fecfa1daa240dd9627ad6bf3bea1b01052e6f18e92eb1214b3f83314f79a592f1c83b843d81ebefeda0a167f63e1749a354e40d392aa2d82112ceab2ec3df0
+EBUILD gbnp-1.0.5.ebuild 574 BLAKE2B c3a77d378755ede2b8a78a88cbe1ae394b8c2743a8a44e47a065cc44a5984f840672b0164eb7a00299de018611429a11ac33a38121b33eb1ee09c59548bd5ccd SHA512 9f6e41d0a5dacde4cc63394f1c7a20a58295d26e4c179a01b6a7c524889b15e4e6fe8e82362c33ea4667d5061c23206ea44f6f6d88da9594fdcf0a5f914d8aff
+MISC metadata.xml 1310 BLAKE2B 736c1a2a33fdfc422293c04d1ecf3dabb276f5e3a57edb08990cf0ea20b186105d0b21594679f40d7c38be9de290e912036093664677f64bd668a75deb625be8 SHA512 4b3297f6b4769bd7fbd1ca3e205c630e2381a700d774cee5b84287e03bc84fe13b5342f81486bd8c37c29661bb340b7116742318c836ef5981dc18d44872691b
diff --git a/dev-gap/gbnp/gbnp-1.0.5.ebuild b/dev-gap/gbnp/gbnp-1.0.5.ebuild
new file mode 100644
index 000000000000..0179f5923969
--- /dev/null
+++ b/dev-gap/gbnp/gbnp-1.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="Compute Gröbner bases of noncommutative polynomials"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+gap-pkg_enable_tests
+
+src_prepare() {
+ # The GNUmakefile is used to produce the tarball, not to build the
+ # package.
+ rm GNUmakefile || die
+ default
+}
+
+src_install() {
+ gap-pkg_src_install
+ use examples && dodoc -r examples
+}
diff --git a/dev-gap/gbnp/metadata.xml b/dev-gap/gbnp/metadata.xml
new file mode 100644
index 000000000000..bfb19d13e1fa
--- /dev/null
+++ b/dev-gap/gbnp/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The GBNP package provides algorithms for computing Grobner bases of
+ noncommutative polynomials with coefficients from a field
+ implemented in GAP and with respect to the "total degree first then
+ lexicographical" ordering. Further provided are some variations,
+ such as a weighted and truncated version and a tracing facility. The
+ word "algorithm" is to be interpreted loosely here: in general one
+ cannot expect such an algorithm to terminate, as it would imply
+ solvability of the word problem for finitely presented (semi)groups.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/gbnp</remote-id>
+ </upstream>
+</pkgmetadata>