summaryrefslogtreecommitdiff
path: root/dev-gap/crypting/crypting-0.10.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-gap/crypting/crypting-0.10.4-r1.ebuild')
-rw-r--r--dev-gap/crypting/crypting-0.10.4-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-gap/crypting/crypting-0.10.4-r1.ebuild b/dev-gap/crypting/crypting-0.10.4-r1.ebuild
new file mode 100644
index 000000000000..b998e7366c3d
--- /dev/null
+++ b/dev-gap/crypting/crypting-0.10.4-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="GAP implementation of SHA256 and HMAC for the Jupyter kernel"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+DEPEND="sci-mathematics/gap:="
+RDEPEND="${DEPEND}"
+
+gap-pkg_enable_tests