summaryrefslogtreecommitdiff
path: root/dev-gap/cohomolo
diff options
context:
space:
mode:
Diffstat (limited to 'dev-gap/cohomolo')
-rw-r--r--dev-gap/cohomolo/Manifest3
-rw-r--r--dev-gap/cohomolo/cohomolo-1.6.11.ebuild27
-rw-r--r--dev-gap/cohomolo/metadata.xml28
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-gap/cohomolo/Manifest b/dev-gap/cohomolo/Manifest
new file mode 100644
index 000000000000..cec5248c4034
--- /dev/null
+++ b/dev-gap/cohomolo/Manifest
@@ -0,0 +1,3 @@
+DIST cohomolo-1.6.11.tar.gz 468966 BLAKE2B 909bc196c67058151cf932781db6399c3091ee38478075bb18d0716f38d607c99e80d09b5a2bc25bc84a06efc172ade54d85da0016ecd474eb4fac03a26b691f SHA512 7bdd64a5ba068e03619427c7add972fe57b7803b4b7a1d40dec485bbdfa032c5b3a44ea4a7fd51a5055235b2d3ac4217971f1143032a2bf1b553dcbc7f71e7f1
+EBUILD cohomolo-1.6.11.ebuild 654 BLAKE2B 85b98046091511801fe6989623d968edc6e1019b7813d8812a940364d31a821318d5af0fcce9b4b2672f688e02d020805ef08ab7545bc0b285a916a86613ab33 SHA512 66114fc9b97456b2f073cc22f88e8df57d3446e7e8ac4128ab6059c2ee78b97ea90699f90df2660ef17975a5ea400ae350ba2cfadc9378ad744b0904fb96d95e
+MISC metadata.xml 980 BLAKE2B 6af01dc7acffdb747d30db282f41720d96f8bfcf09b847b5d5c88a9e6e76b3c2e388483c3c9a7e5b98ae9d0c6fa280c0b9ff300ef4b90deaf095c1956eb74bfd SHA512 613d7b42356c1fdd9995cc953b710f6e779690e3569f025d9e3fdb78bbe4bd144441a471fa40a845837f591586cbbfaa99b076e8e13d2fb34e98f5a2faab5201
diff --git a/dev-gap/cohomolo/cohomolo-1.6.11.ebuild b/dev-gap/cohomolo/cohomolo-1.6.11.ebuild
new file mode 100644
index 000000000000..7756fd073fb0
--- /dev/null
+++ b/dev-gap/cohomolo/cohomolo-1.6.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="Cohomology groups of finite groups on finite modules"
+SLOT="0"
+SRC_URI="https://github.com/gap-packages/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+
+DEPEND="sci-mathematics/gap"
+
+GAP_PKG_HTML_DOCDIR="htm"
+GAP_PKG_EXTRA_INSTALL=( testdata standalone )
+
+gap-pkg_enable_tests
+
+src_install() {
+ # Remove standalone/progs.d so that it is not installed below. It
+ # contains the source code for the executable that we built.
+ rm -r standalone/progs.d || die
+ gap-pkg_src_install
+}
diff --git a/dev-gap/cohomolo/metadata.xml b/dev-gap/cohomolo/metadata.xml
new file mode 100644
index 000000000000..8d1cf3fb1bd4
--- /dev/null
+++ b/dev-gap/cohomolo/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The cohomolo package is a GAP interface to some C programs for
+ computing Schur multipliers and covering groups of finite groups and
+ first and second cohomology groups of finite groups acting on finite
+ modules.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gap-packages/cohomolo</remote-id>
+ </upstream>
+</pkgmetadata>