summaryrefslogtreecommitdiff
path: root/dev-gap/atlasrep
diff options
context:
space:
mode:
Diffstat (limited to 'dev-gap/atlasrep')
-rw-r--r--dev-gap/atlasrep/Manifest7
-rw-r--r--dev-gap/atlasrep/atlasrep-2.1.7.ebuild62
-rw-r--r--dev-gap/atlasrep/files/atlasrep-2.1.7-no-remote-access.patch27
-rw-r--r--dev-gap/atlasrep/files/atlasrep-2.1.7-non-writable-data-dir.patch34
-rw-r--r--dev-gap/atlasrep/metadata.xml25
5 files changed, 155 insertions, 0 deletions
diff --git a/dev-gap/atlasrep/Manifest b/dev-gap/atlasrep/Manifest
new file mode 100644
index 000000000000..90e8b129548c
--- /dev/null
+++ b/dev-gap/atlasrep/Manifest
@@ -0,0 +1,7 @@
+AUX atlasrep-2.1.7-no-remote-access.patch 818 BLAKE2B 0f4604baf23cfa8d14ff72c48532fbc75a62ea18bd9965c5b4e46a29dc24eec98219c7596705ebfd44343b5d66d9c680652f72ae06af49ce1292ef03c54b2e16 SHA512 df221eef6f86a2047fa9164a0d0e337bb28e7657bb913bb485a0842c0ca006b064b50bfbc354b16ea4c53b49febfff223de786c8aaee7a9e4792e222769add39
+AUX atlasrep-2.1.7-non-writable-data-dir.patch 1140 BLAKE2B 8f0cdda850a5a89a3629db8b5999d9f762c90aa0e18a14c9fd5af2accd8745a40ac73ed9b570fd681b98f780cd1ea269770c937fcb04dc0bb4da4c69ac6612b8 SHA512 0c4a8515e931812e4b4e27a5efac455c83db26148ba094834b6ceff59b12827cfbb52d4735ef87df6debad21db30868b8328f9d1603e25ead8a2403d5a8e8f67
+DIST atlasrep-2.1.7-testdata.tar.xz 386468 BLAKE2B d1ef21fa465514fd48acf09b9a73bee91f35093541ae50d734343a9d2daf9590039f6afacb242723a49d25000e678ec13d56635e12a85d72a9fa8eaf936abdfd SHA512 065719e35733c28cd46bab7c719ea70ce61e6fde7fffe722d8d98eeef39d385dc298ed562c739cb45ee3f61a1c2942cdd465a7f043b190a2117db97dbba984f2
+DIST atlasrep-2.1.7.tar.gz 2238864 BLAKE2B 491fabc2bc970b9f2ba4dafe2e07fb69b2ec24e36655531b27e9457720578fa7df0dabb4df3091a06beb822d574d787d036b948970cbd5b63d42885631321552 SHA512 df1846331a4d2a00145e8e2650fc3c4747973b963eae1582b719b5b3204ad473e3a287534c45f95dc7d9020e9fc75f9e4f3bb6c99393a900f3579ac276c968ee
+DIST atlasrepdata.tar.gz 22203132 BLAKE2B 1bc5f9c4045b46ab98d48482569134ac8141868fdb3082b453a9a90dfbf8c780faa6da177d0db115dcdd59a04fe1dbbea662a598b2a53cc81a79a88cfb3f6ee0 SHA512 fc1d594eb23486163081360f63c63ee6b81e7cc72f97c3c5a377d7cfd7f93ce1ae0228ba9bd3032f9d1e2ea68150524bbb4a98b73507458d6e23692b35de3151
+EBUILD atlasrep-2.1.7.ebuild 1551 BLAKE2B 0f6d40f0372dace1857f87948c21d65b6a22da6e49694a63d1ec060e85ed6788d49bdf3d58bc42c374181d7380175cd64a3c700b76f7347f94c2b0a061a87d6e SHA512 8088b93583832a831835b4df20b3becc758e47f2195e2e4ae656dbe1cd3047b1c4dddc80d3d8a2a7329d65eb39faa2ce82ba74d0b09788e50ae9e94b031626f3
+MISC metadata.xml 925 BLAKE2B ca5ce6fb4130cca3725573608ce97e59502f15c32586b39fe1dc27957551751ac5b73aff9277f8f4dcf391c5301bcf13ce75de593fe5ef3d4880e21069faed92 SHA512 ceae388701b8b45f158dd0c3b8aa6d193eb4f0b0da9d62c7a328dc33e21c7bf032068e67370ebb67c63b418fcf0f6d1a4ecff49c34a301cd4eae0849b37a472d
diff --git a/dev-gap/atlasrep/atlasrep-2.1.7.ebuild b/dev-gap/atlasrep/atlasrep-2.1.7.ebuild
new file mode 100644
index 000000000000..15af7966d7c4
--- /dev/null
+++ b/dev-gap/atlasrep/atlasrep-2.1.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="GAP Interface to the Atlas of Group Representations"
+
+# How to make the test data:
+#
+# gap> SetUserPreference("AtlasRep", "AtlasRepDataDirectory", "some-dir");
+# gap> SetUserPreference("AtlasRep", "AtlasRepAccessRemoteFiles", true);
+# gap> TestPackage("atlasrep"); TestPackage("orb"); ...
+#
+# Then tar up some-dir. This runs the test suite with downloading enabled,
+# so you wind up downloading all of the data you need into some-dir (which
+# has to be writable).
+SRC_URI="https://www.math.rwth-aachen.de/~Thomas.Breuer/atlasrep/${P}.tar.gz
+ https://www.math.rwth-aachen.de/homes/Thomas.Breuer/atlasrep/atlasrepdata.tar.gz
+ https://dev.gentoo.org/~mjo/distfiles/${P}-testdata.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-gap/io
+ dev-gap/utils"
+
+BDEPEND="test? (
+ dev-gap/tomlib
+)"
+gap-pkg_enable_tests
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-remote-access.patch"
+ "${FILESDIR}/${P}-non-writable-data-dir.patch"
+)
+
+GAP_PKG_EXTRA_INSTALL=(
+ atlasprm.json
+ atlasprm_SHA.json
+ bibl
+ dataext
+ datagens
+ datapkg
+ dataword
+)
+
+src_prepare() {
+ # Move the pre-downloaded data into the empty directories where the
+ # package expects them to be. The archive atlasrepdata.tar.gz
+ # expands to a directory called "atlasrep".
+ for s in ext gens word; do
+ mv "${WORKDIR}/atlasrep/data${s}/"* "data${s}"/ || die
+ done
+ rm data{gens,word}/dummy || die
+
+ default
+}
diff --git a/dev-gap/atlasrep/files/atlasrep-2.1.7-no-remote-access.patch b/dev-gap/atlasrep/files/atlasrep-2.1.7-no-remote-access.patch
new file mode 100644
index 000000000000..0bc0afe410b8
--- /dev/null
+++ b/dev-gap/atlasrep/files/atlasrep-2.1.7-no-remote-access.patch
@@ -0,0 +1,27 @@
+From 73fee69243be30b25af3322dc66ad061c5d8fa38 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sat, 16 Dec 2023 13:41:05 -0500
+Subject: [PATCH 1/2] gap/userpref.g: disable AtlasRepAccessRemoteFiles by
+ default
+
+On Gentoo, we include all of the available data by default.
+---
+ gap/userpref.g | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gap/userpref.g b/gap/userpref.g
+index 067ddf1..75140b9 100644
+--- a/gap/userpref.g
++++ b/gap/userpref.g
+@@ -44,7 +44,7 @@ information shown by 'DisplayAtlasInfo', \
+ this information depends on the value of the preference at the time \
+ when the AtlasRep package and its data extensions get loaded."
+ ],
+- default:= true,
++ default:= false,
+ values:= [ true, false ],
+ multi:= false,
+ package:= "AtlasRep",
+--
+2.41.0
+
diff --git a/dev-gap/atlasrep/files/atlasrep-2.1.7-non-writable-data-dir.patch b/dev-gap/atlasrep/files/atlasrep-2.1.7-non-writable-data-dir.patch
new file mode 100644
index 000000000000..545d46799fb2
--- /dev/null
+++ b/dev-gap/atlasrep/files/atlasrep-2.1.7-non-writable-data-dir.patch
@@ -0,0 +1,34 @@
+From 3df6f42de798f0b5ab758d5886606c2bbc5c364f Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sat, 16 Dec 2023 13:43:36 -0500
+Subject: [PATCH 2/2] gap/userpref.g: allow non-writable AtlasRepDataDirectory
+
+On Gentoo, all of the data is already there. So there's no reason to
+download it. So there's no requirement for the directory to be
+writable. (Remote access is disabled by default anyway.)
+---
+ gap/userpref.g | 8 +-------
+ 1 file changed, 1 insertion(+), 7 deletions(-)
+
+diff --git a/gap/userpref.g b/gap/userpref.g
+index 75140b9..2d497ee 100644
+--- a/gap/userpref.g
++++ b/gap/userpref.g
+@@ -94,13 +94,7 @@ otherwise the default is an empty string."
+ local dir;
+
+ dir:= DirectoriesPackageLibrary( "atlasrep", "" );
+- if ForAll( [ "dataext", "datagens", "dataword" ],
+- subdir -> IsWritableFile( Filename( dir, subdir ) ) ) then
+- # The package directory is the first default.
+- return Filename( dir, "" );
+- else
+- return "";
+- fi;
++ return Filename( dir, "" );
+ end,
+ package:= "AtlasRep",
+ check:= function( val )
+--
+2.41.0
+
diff --git a/dev-gap/atlasrep/metadata.xml b/dev-gap/atlasrep/metadata.xml
new file mode 100644
index 000000000000..30a102567b7f
--- /dev/null
+++ b/dev-gap/atlasrep/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ AtlasRep provides an interface between GAP and databases such as the
+ Atlas of Group Representations, which comprises representations of
+ many almost simple groups and information about their maximal
+ subgroups, and is included in the GAP package.
+ </longdescription>
+</pkgmetadata>