summaryrefslogtreecommitdiff
path: root/dev-games
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/Manifest.gzbin5727 -> 5729 bytes
-rw-r--r--dev-games/physfs/Manifest1
-rw-r--r--dev-games/physfs/files/GNUInstallDirs.patch74
3 files changed, 0 insertions, 75 deletions
diff --git a/dev-games/Manifest.gz b/dev-games/Manifest.gz
index 810e470246ad..fe04e543536a 100644
--- a/dev-games/Manifest.gz
+++ b/dev-games/Manifest.gz
Binary files differ
diff --git a/dev-games/physfs/Manifest b/dev-games/physfs/Manifest
index 08172c454c9b..bbedf3d5f4ae 100644
--- a/dev-games/physfs/Manifest
+++ b/dev-games/physfs/Manifest
@@ -1,4 +1,3 @@
-AUX GNUInstallDirs.patch 2430 BLAKE2B 8eeebb7bd59273ef5a35e49a98a30bb0fde320231c9482532086fd653f97636c042edf98ad58473ae1ff28c1c10a392e4ded5d0818c27ba00b2b0ec3825d00c8 SHA512 cacae41b22e06836b44f0ceba91961945d4d5cbd60318eeb89b39023dfa00d201c5cd61c5f451c33996698a4757070614486ea859bb943a31a0453b8d598b8d6
DIST physfs-3.2.0.tar.gz 242857 BLAKE2B 7766c63b1048f0a97b1e52b17db60ab7db2f9bbca2bf3fc5cba97e029cfef7e0273fbf1db80706a1f6d5fd8f12afd8115f7769b8b2b96e3c1ab4a0057dbc1a2d SHA512 e0d84d6ac6bd8f0973149a5add54ed5ed890b5fabb4592ba61b59a3b3e01c05e05f1754f18d7a1c8d72e68777a23cda0c50dc0512cf57a8310a950bf908f54b1
EBUILD physfs-3.2.0.ebuild 1439 BLAKE2B 1454cf57c75425bd33fd50f2d2b3992ce077192a49be21e0c5cbe046a544fda869c6df23d2a300090111a482ee5d29e7c1f11f0139dfeeecb92af5d7b10522b2 SHA512 a1131b1bb41d55e7b95cacd85322f7ebb442713b92ebbb67254b878e57d300ff373466dfda39b64fcdf45bf042e396082ddd510c811115adb812625f2deb66cb
EBUILD physfs-9999.ebuild 1379 BLAKE2B 45d6984857bc246ba5490dff8743fb77a60aac4c772ebd398e68ca5ae46c5a3771734fb0a515fb529ec64fd104ab3d044ebf67af9a0e0d508afe661ee22f08c9 SHA512 ccdf81354770e6571e182b7d1d6f39cd10db05c3c6da5c34cc3316249601968ab83d262ae20ba3cb99820cf12099ab232c7e4b938ca1c08cf8701519d9cb7686
diff --git a/dev-games/physfs/files/GNUInstallDirs.patch b/dev-games/physfs/files/GNUInstallDirs.patch
deleted file mode 100644
index ef7bb5d1f147..000000000000
--- a/dev-games/physfs/files/GNUInstallDirs.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 727d7a5265ad856fd473ad1c621d6c03dd306d6d Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Sat, 10 Jul 2021 22:55:53 +0100
-Subject: [PATCH] Use the GNUInstallDirs CMake module to respect installation
- locations
-
-Apparently use of LIB_SUFFIX is now discouraged. GNUInstallDirs does a
-better job of setting a default.
-
-The libdir of ${prefix}/lib in the pkg-config file caused warnings,
-and possibly even failures, when linking on multilib systems where
-/usr/lib is for 32-bit libraries rather than 64-bit libraries.
----
- CMakeLists.txt | 15 ++++++++-------
- extras/physfs.pc.in | 6 +++---
- 2 files changed, 11 insertions(+), 10 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 4a67c27..6c26cb1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -14,6 +14,8 @@ cmake_minimum_required(VERSION 2.8.4)
- project(PhysicsFS)
- set(PHYSFS_VERSION 3.0.2)
-
-+include(GNUInstallDirs)
-+
- # Increment this if/when we break backwards compatibility.
- set(PHYSFS_SOVERSION 1)
-
-@@ -213,11 +215,11 @@ if(PHYSFS_BUILD_TEST)
- set(PHYSFS_INSTALL_TARGETS ${PHYSFS_INSTALL_TARGETS} ";test_physfs")
- endif()
-
--install(TARGETS ${PHYSFS_INSTALL_TARGETS}
-- RUNTIME DESTINATION bin
-- LIBRARY DESTINATION lib${LIB_SUFFIX}
-- ARCHIVE DESTINATION lib${LIB_SUFFIX})
--install(FILES src/physfs.h DESTINATION include)
-+install(TARGETS ${PHYSFS_INSTALL_TARGETS} EXPORT PhysFSExport
-+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+install(FILES src/physfs.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
-
- find_package(Doxygen)
- if(DOXYGEN_FOUND)
-@@ -271,7 +273,7 @@ if(NOT MSVC)
- )
- install(
- FILES "${CMAKE_CURRENT_BINARY_DIR}/extras/physfs.pc"
-- DESTINATION "lib${LIB_SUFFIX}/pkgconfig"
-+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig"
- )
- endif()
-
-diff --git a/extras/physfs.pc.in b/extras/physfs.pc.in
-index 6cd0972..f7e0307 100644
---- a/extras/physfs.pc.in
-+++ b/extras/physfs.pc.in
-@@ -1,7 +1,7 @@
- prefix=@CMAKE_INSTALL_PREFIX@
--exec_prefix=${prefix}
--libdir=${exec_prefix}/lib
--includedir=${prefix}/include
-+exec_prefix=@CMAKE_INSTALL_PREFIX@
-+libdir=@CMAKE_INSTALL_FULL_LIBDIR@
-+includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
-
- Name: PhysicsFS
- Description: PhysicsFS is a library to provide abstract access to various archives.
---
-2.31.1
-