summaryrefslogtreecommitdiff
path: root/dev-games/recastnavigation/files/recastnavigation-1.5.1_p20230102-catch.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/recastnavigation/files/recastnavigation-1.5.1_p20230102-catch.patch')
-rw-r--r--dev-games/recastnavigation/files/recastnavigation-1.5.1_p20230102-catch.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-games/recastnavigation/files/recastnavigation-1.5.1_p20230102-catch.patch b/dev-games/recastnavigation/files/recastnavigation-1.5.1_p20230102-catch.patch
new file mode 100644
index 000000000000..5b0ff9bc6017
--- /dev/null
+++ b/dev-games/recastnavigation/files/recastnavigation-1.5.1_p20230102-catch.patch
@@ -0,0 +1,10 @@
+--- a/Tests/CMakeLists.txt
++++ b/Tests/CMakeLists.txt
+@@ -10,5 +10,6 @@ add_executable(Tests ${TESTS_SOURCES})
+ set_property(TARGET Tests PROPERTY CXX_STANDARD 17)
+
+ add_dependencies(Tests Recast Detour)
+-target_link_libraries(Tests Recast Detour)
++find_package(Catch2 REQUIRED)
++target_link_libraries(Tests Recast Detour Catch2::Catch2WithMain)
+ add_test(Tests Tests)