summaryrefslogtreecommitdiff
path: root/dev-games/openscenegraph-openmw/files/openscenegraph-3.6.5-cmake_lua_version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/openscenegraph-openmw/files/openscenegraph-3.6.5-cmake_lua_version.patch')
-rw-r--r--dev-games/openscenegraph-openmw/files/openscenegraph-3.6.5-cmake_lua_version.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-games/openscenegraph-openmw/files/openscenegraph-3.6.5-cmake_lua_version.patch b/dev-games/openscenegraph-openmw/files/openscenegraph-3.6.5-cmake_lua_version.patch
new file mode 100644
index 000000000000..1373b296da04
--- /dev/null
+++ b/dev-games/openscenegraph-openmw/files/openscenegraph-3.6.5-cmake_lua_version.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -771,10 +771,7 @@
+ FIND_PACKAGE(LIBLAS)
+
+ IF (NOT(OSG_USE_LOCAL_LUA_SOURCE))
+- FIND_PACKAGE(Lua52)
+- IF (NOT (LUA_LIBRARIES AND LUA_INCLUDE_DIR))
+- FIND_PACKAGE(Lua51)
+- ENDIF()
++ FIND_PACKAGE(Lua ${LUA_VERSION} EXACT)
+ ENDIF()
+
+ # V8 and Python plugins are tests for linking against these libraries but aren't functionality beyond this.