summaryrefslogtreecommitdiff
path: root/dev-games/ois/ois-1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/ois/ois-1.3.ebuild')
-rw-r--r--dev-games/ois/ois-1.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-games/ois/ois-1.3.ebuild b/dev-games/ois/ois-1.3.ebuild
new file mode 100644
index 000000000000..a7572e973690
--- /dev/null
+++ b/dev-games/ois/ois-1.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools autotools-utils
+
+MY_P=${PN}-v${PV/./-}
+DESCRIPTION="Object-oriented Input System - A cross-platform C++ input handling library"
+HOMEPAGE="https://sourceforge.net/projects/wgois/"
+SRC_URI="mirror://sourceforge/wgois/${MY_P/-/_}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="static-libs"
+
+DEPEND="x11-libs/libXaw
+ x11-libs/libX11"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ eautoreconf
+}