summaryrefslogtreecommitdiff
path: root/dev-games/newton/newton-3.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/newton/newton-3.13.ebuild')
-rw-r--r--dev-games/newton/newton-3.13.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-games/newton/newton-3.13.ebuild b/dev-games/newton/newton-3.13.ebuild
new file mode 100644
index 000000000000..83b67791e5ce
--- /dev/null
+++ b/dev-games/newton/newton-3.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs cmake-utils
+
+MY_P="${PN}-dynamics-${P}"
+DESCRIPTION="an integrated solution for real time simulation of physics environments"
+HOMEPAGE="http://newtondynamics.com/forum/newton.php"
+SRC_URI="https://github.com/MADEAPPS/newton-dynamics/archive/${P}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e '/packages/d' CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=/usr/
+ -DNEWTON_DEMOS_SANDBOX=OFF
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_install
+}