summaryrefslogtreecommitdiff
path: root/dev-games/mygui/files/mygui-3.4.3-werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/mygui/files/mygui-3.4.3-werror.patch')
-rw-r--r--dev-games/mygui/files/mygui-3.4.3-werror.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-games/mygui/files/mygui-3.4.3-werror.patch b/dev-games/mygui/files/mygui-3.4.3-werror.patch
new file mode 100644
index 000000000000..d001c9e48baf
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.4.3-werror.patch
@@ -0,0 +1,12 @@
+Remove -Werror
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -174,7 +174,6 @@ include(Dependencies)
+
+ # Set compiler specific build flags
+ if (CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR CMAKE_CXX_COMPILER_ID MATCHES "Intel")
+- add_compile_options(-Werror)
+ if (NOT MYGUI_HIGH_LEVEL_WARNINGS)
+ add_compile_options(-w)
+ else ()