summaryrefslogtreecommitdiff
path: root/dev-games/irrlicht
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/irrlicht')
-rw-r--r--dev-games/irrlicht/Manifest4
-rw-r--r--dev-games/irrlicht/irrlicht-1.8.4.ebuild73
-rw-r--r--dev-games/irrlicht/metadata.xml21
3 files changed, 98 insertions, 0 deletions
diff --git a/dev-games/irrlicht/Manifest b/dev-games/irrlicht/Manifest
new file mode 100644
index 000000000000..164d7be056a6
--- /dev/null
+++ b/dev-games/irrlicht/Manifest
@@ -0,0 +1,4 @@
+DIST irrlicht-1.8.4-patchset.tar.bz2 4813 BLAKE2B acad0f0dcc2ff5778608d0620063e7c70935838447f4bd1b241e08fb24f69531c29d96e95de394a3018e239fd7865bc3b50dc9ed5d54dd171b7b51df6c740b4d SHA512 5035cdf42fd26449d03e849ca248f6abcfcea1b0e9827683f00be2545ce90e3979e41c94fd487cfb1c67450e2e973f872d11d233c5a5b654700cec2ccb7f5602
+DIST irrlicht-1.8.4.zip 27927144 BLAKE2B 2c2d7e1306b169e537258152f88b11578d8a33c0ebe58e7ee48242048b70b9ba01069fcf272e44e18f7afbd1e6ec89d6bd86289d203929388e6b96871c048a98 SHA512 de69ddd2c6bc80a1b27b9a620e3697b1baa552f24c7d624076d471f3aecd9b15f71dce3b640811e6ece20f49b57688d428e3503936a7926b3e3b0cc696af98d1
+EBUILD irrlicht-1.8.4.ebuild 1791 BLAKE2B fa82391d90d0d1ab65a621e52318c509d30285caddfac29d39dff1300bb04924b0f6012754c856f864185db4b65287d2bc494b4232733ce7a39f855e26be9b3e SHA512 b2e2891bcffa536532c3bbf7ccb9f93a4dd1c9e73f33fd8997394349379ee44e05de0a54af5362dad7f5a80b1841dab740e07812ef9dfbd674cea6bf44fcff89
+MISC metadata.xml 964 BLAKE2B 53a776bc251d381e194ad54eb4f0a24e3d1b0729281d69e1f48d1b744a1de1f33b7e5b400123d4cd04aa74a3e5db0a00682a67f389744fd33c4307437d0e5a30 SHA512 858c0cf4a2ac22ca6728a1449e59fd7a8c098a01587cd039e725b26ee71feb13217036f24bb5de2cbde6f27855eeb0347b43887a56f64a6f7a98f47b0f481503
diff --git a/dev-games/irrlicht/irrlicht-1.8.4.ebuild b/dev-games/irrlicht/irrlicht-1.8.4.ebuild
new file mode 100644
index 000000000000..e843c52e456a
--- /dev/null
+++ b/dev-games/irrlicht/irrlicht-1.8.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="open source high performance realtime 3D engine written in C++"
+HOMEPAGE="http://irrlicht.sourceforge.net/"
+SRC_URI="mirror://sourceforge/irrlicht/${P}.zip
+ https://dev.gentoo.org/~mgorny/dist/${P}-patchset.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug doc static-libs"
+
+RDEPEND="virtual/jpeg:0
+ media-libs/libpng:0=
+ app-arch/bzip2
+ sys-libs/zlib
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ x11-base/xorg-proto"
+
+S=${WORKDIR}/${P}/source/${PN^}
+
+PATCHES=( "${WORKDIR}"/${P}-patchset/${P}-gentoo.patch
+ "${WORKDIR}"/${P}-patchset/${P}-config.patch
+ "${WORKDIR}"/${P}-patchset/${P}-demoMake.patch
+ "${WORKDIR}"/${P}-patchset/${P}-mesa-10.x.patch
+ "${WORKDIR}"/${P}-patchset/${P}-jpeg-9a.patch )
+
+DOCS=( changes.txt readme.txt )
+
+src_prepare() {
+ cd "${WORKDIR}"/${P} || die
+ edos2unix include/IrrCompileConfig.h
+ sed -i \
+ -e 's:\.\./\.\./media:../media:g' \
+ $(grep -rl '\.\./\.\./media' examples) \
+ || die 'sed failed'
+ default
+}
+
+src_compile() {
+ tc-export CXX CC AR
+ emake NDEBUG=$(usex debug "" "1") sharedlib $(usex static-libs "staticlib" "")
+}
+
+src_install() {
+ cd "${WORKDIR}"/${P} || die
+
+ use static-libs && dolib.a lib/Linux/libIrrlicht.a
+ dolib.so lib/Linux/libIrrlicht.so*
+
+ # create library symlinks
+ dosym libIrrlicht.so.${PV} /usr/$(get_libdir)/libIrrlicht.so.1.8
+ dosym libIrrlicht.so.${PV} /usr/$(get_libdir)/libIrrlicht.so
+
+ insinto /usr/include/${PN}
+ doins include/*
+
+ einstalldocs
+
+ # don't do these with einstalldocs because they shouldn't be compressed
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples media
+ fi
+}
diff --git a/dev-games/irrlicht/metadata.xml b/dev-games/irrlicht/metadata.xml
new file mode 100644
index 000000000000..d7f0def17f75
--- /dev/null
+++ b/dev-games/irrlicht/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription>
+The Irrlicht Engine is an open source high performance realtime 3D engine written in
+C++. It is completely cross-platform, using D3D, OpenGL and its own software renderer,
+and has all of the state-of-the-art features which can be found in commercial 3d
+engines.
+We've got a huge active community, and there are lots of games in development that use
+the engine. You can find enhancements for Irrlicht all over the web, like alternative
+terrain renderers, portal renderers, world layers, tutorials, editors, bindings for
+perl, ruby, python, and so on. And best of all: It's completely free.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">irrlicht</remote-id>
+ </upstream>
+</pkgmetadata>