summaryrefslogtreecommitdiff
path: root/dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch')
-rw-r--r--dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch b/dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch
new file mode 100644
index 000000000000..a3500e22f7e1
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-4.0.0-fix-build-system.patch
@@ -0,0 +1,25 @@
+* Fix AM_CONDITIONAL to always be invoked
+* Install html files in proper --htmldir
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -437,8 +437,8 @@
+ fi
+
+ if test "$enable_clanSound" = "auto"; then enable_clanSound=yes; fi
+- AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+ fi
++AM_CONDITIONAL(ALSA, test x$have_alsa = xyes)
+
+ if test "$enable_clanNetwork" != "no"; then
+ echo "Checking for clanNetwork stuff"
+--- a/Documentation/Makefile.am
++++ b/Documentation/Makefile.am
+@@ -1,6 +1,6 @@
+ EXTRA_DIST = $(wildcart images/*.png)
+
+-HTML_PREFIX = $(datadir)/doc/@PACKAGE@-@LT_RELEASE@
++HTML_PREFIX = $(htmldir)
+
+ all-local:
+