summaryrefslogtreecommitdiff
path: root/dev-erlang/xmpp/xmpp-1.1.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-erlang/xmpp/xmpp-1.1.9.ebuild')
-rw-r--r--dev-erlang/xmpp/xmpp-1.1.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-erlang/xmpp/xmpp-1.1.9.ebuild b/dev-erlang/xmpp/xmpp-1.1.9.ebuild
new file mode 100644
index 000000000000..8b5fd3bf6a43
--- /dev/null
+++ b/dev-erlang/xmpp/xmpp-1.1.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="XMPP parsing and serialization library on top of Fast XML"
+HOMEPAGE="https://github.com/processone/xmpp"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
+IUSE="test"
+
+RDEPEND=">=dev-erlang/fast_xml-1.1.22
+ >=dev-erlang/stringprep-1.0.8
+ >=dev-lang/erlang-17.1"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md )
+
+src_prepare() {
+ rebar_src_prepare
+ rebar_fix_include_path fast_xml
+}