summaryrefslogtreecommitdiff
path: root/dev-erlang/meck/meck-0.8.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-erlang/meck/meck-0.8.13.ebuild')
-rw-r--r--dev-erlang/meck/meck-0.8.13.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-erlang/meck/meck-0.8.13.ebuild b/dev-erlang/meck/meck-0.8.13.ebuild
new file mode 100644
index 000000000000..51e2eec93ba1
--- /dev/null
+++ b/dev-erlang/meck/meck-0.8.13.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Mocking library for Erlang"
+HOMEPAGE="https://github.com/eproxus/meck"
+SRC_URI="https://github.com/eproxus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md NOTICE README.md )
+
+# Tests need rebar3. The build somewhat works with rebar2.
+RESTRICT="test"