summaryrefslogtreecommitdiff
path: root/dev-erlang/jose/jose-1.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-erlang/jose/jose-1.9.0.ebuild')
-rw-r--r--dev-erlang/jose/jose-1.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-erlang/jose/jose-1.9.0.ebuild b/dev-erlang/jose/jose-1.9.0.ebuild
new file mode 100644
index 000000000000..4f337f565a5e
--- /dev/null
+++ b/dev-erlang/jose/jose-1.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="JSON Object Signing and Encryption (JOSE) for Erlang and Elixir"
+HOMEPAGE="https://github.com/potatosalad/erlang-jose"
+SRC_URI="https://github.com/potatosalad/erlang-jose/archive/${PV}.tar.gz
+ -> erlang-${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/erlang-19.0
+ >=dev-erlang/base64url-1.0"
+RDEPEND="${DEPEND}"
+
+DOCS=( ALGORITHMS.md CHANGELOG.md README.md examples/KEY-GENERATION.md )
+
+# TODO: jose has test suite, but it require lots of dependencies. It may not be
+# TODO: urgent, but it would be nice to have those sooner or later.
+RESTRICT=test
+
+S="${WORKDIR}/erlang-${P}"