summaryrefslogtreecommitdiff
path: root/dev-erlang/hamcrest/hamcrest-0.1.0_p20150103.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-erlang/hamcrest/hamcrest-0.1.0_p20150103.ebuild')
-rw-r--r--dev-erlang/hamcrest/hamcrest-0.1.0_p20150103.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-erlang/hamcrest/hamcrest-0.1.0_p20150103.ebuild b/dev-erlang/hamcrest/hamcrest-0.1.0_p20150103.ebuild
new file mode 100644
index 000000000000..66f111f47de2
--- /dev/null
+++ b/dev-erlang/hamcrest/hamcrest-0.1.0_p20150103.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang port of Hamcrest"
+HOMEPAGE="https://github.com/hyperthunk/hamcrest-erlang"
+SRC_URI="https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1
+ <dev-lang/erlang-19"
+DEPEND="${CDEPEND}
+ test? ( >=dev-erlang/proper-1.1 )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( NOTES README.markdown TODO.md )
+PATCHES=( "${FILESDIR}"/${PV}-0001-Fix-unittests.patch )
+
+# Override with EAPI default because it's missing hamcrest.app.src and doesn't
+# have any deps.
+src_prepare() {
+ default
+}
+
+src_test() {
+ rebar_remove_deps test.config
+ erebar -C test.config compile ct
+}