summaryrefslogtreecommitdiff
path: root/dev-erlang/fast_tls/fast_tls-1.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-erlang/fast_tls/fast_tls-1.1.2.ebuild')
-rw-r--r--dev-erlang/fast_tls/fast_tls-1.1.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-erlang/fast_tls/fast_tls-1.1.2.ebuild b/dev-erlang/fast_tls/fast_tls-1.1.2.ebuild
new file mode 100644
index 000000000000..a51677b11bc7
--- /dev/null
+++ b/dev-erlang/fast_tls/fast_tls-1.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="TLS/SSL native driver for Erlang and Elixir"
+HOMEPAGE="https://github.com/processone/fast_tls"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="libressl"
+
+DEPEND=">=dev-erlang/p1_utils-1.0.16
+ >=dev-lang/erlang-17.1
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )