summaryrefslogtreecommitdiff
path: root/dev-erlang/epam/epam-1.0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-erlang/epam/epam-1.0.8.ebuild')
-rw-r--r--dev-erlang/epam/epam-1.0.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-erlang/epam/epam-1.0.8.ebuild b/dev-erlang/epam/epam-1.0.8.ebuild
new file mode 100644
index 000000000000..bc3c599bafe4
--- /dev/null
+++ b/dev-erlang/epam/epam-1.0.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar user
+
+DESCRIPTION="epam for ejabberd to help with PAM authentication support"
+HOMEPAGE="https://github.com/processone/epam"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+pkg_setup() {
+ enewgroup "${PN}"
+}
+
+src_install() {
+ rebar_src_install
+
+ local epam_path="$(get_erl_libs)/${P}/priv/bin/epam"
+ fowners root:"${PN}" "${epam_path}"
+ fperms 4750 "${epam_path}"
+}