summaryrefslogtreecommitdiff
path: root/dev-embedded
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/Manifest.gzbin9383 -> 9379 bytes
-rw-r--r--dev-embedded/arduino-ctags/Manifest4
-rw-r--r--dev-embedded/arduino-ctags/arduino-ctags-20161123-r2.ebuild (renamed from dev-embedded/arduino-ctags/arduino-ctags-20161123-r1.ebuild)11
-rw-r--r--dev-embedded/arduino-ctags/files/arduino-ctags-20161123-implicit-exit.patch21
-rw-r--r--dev-embedded/arduino-ctags/files/arduino-ctags-20161123-implicit-int.patch12
5 files changed, 46 insertions, 2 deletions
diff --git a/dev-embedded/Manifest.gz b/dev-embedded/Manifest.gz
index c849cd3aa037..71fc224ac97a 100644
--- a/dev-embedded/Manifest.gz
+++ b/dev-embedded/Manifest.gz
Binary files differ
diff --git a/dev-embedded/arduino-ctags/Manifest b/dev-embedded/arduino-ctags/Manifest
index ef3d921f4059..819ed45eb5a4 100644
--- a/dev-embedded/arduino-ctags/Manifest
+++ b/dev-embedded/arduino-ctags/Manifest
@@ -1,4 +1,6 @@
AUX arduino-ctags-20161123-gcc-unused-attribute.patch 6945 BLAKE2B 4536d675618ffb264e432479a29916b14c9a52e39a8147e26497b7daf1f5da5d42017339b51778ef0befdc818953df8139fa11667e052c27754f06d274436cbb SHA512 2ff6a3d05afead970fcc767b1feb1c78df313af82ef8214ad57b3bb25106912f6bdfca7b16650307464ccaa83f7d769e41c46ff2454b6071614a6b8c08edfbd5
+AUX arduino-ctags-20161123-implicit-exit.patch 776 BLAKE2B fbb49c970104a693090baf15a68325138b0e8abe800c5b545adf90056156f8cdd7290df1a86c52503353456606d49832a07d75e48b6521345daf76c01b071a65 SHA512 d1035dfc597ca3e3339b372963ffe870b0ff2c7f809406aa7a3c037af4e3b6cad1f3d9a281d8b2f5acc0148a3f98bc6dfd698cbef6f01c9f4129e44f22659f6d
+AUX arduino-ctags-20161123-implicit-int.patch 594 BLAKE2B 90078133a54ee05508ebdfda853b0bab32540428d3671d8791f0634fa2ef5a654b53fe73ed70b5b7e51a26ce5406dc188ea2c09629abfe22213d867b98250a61 SHA512 1d7fc1e23a991d68c979f35e5aefad045877cc1738a90342d8666706bfc28697e3f31ecb456d20f041d1c9b9ea928545cacf9dc6ce83bb09660802afa026f6d4
DIST arduino-ctags-20161123.tar.gz 490200 BLAKE2B f51b18a0db420124c5fed2b320c16d9eeb96fce6d0f118cf43a8177f88400daaeb83437c3993353c16b73781961c7476e782e66891582f4b3dc5301c73da64dc SHA512 ae5bde92c3dd0b9a179bc1df998f20312c4ab8b2c9c1840dbe543d23fb4531b9e5524f1399d9922ed9b2de4582bdb74635f7ec576a42c808d152c3fbb84f9687
-EBUILD arduino-ctags-20161123-r1.ebuild 809 BLAKE2B 866a83226309df51f7751b1f758fde526bbf2bda24dfee754884f0c0d511ced322cb15eed94323265b06a09e293ec43a3b0470cb9f683425a1dbbed525bed7ed SHA512 722d4081c6cfc084164ce17c81f11071ab935c66928a548638236b278d8992a0d22e26ff32d724aacaaa51a3fbb1c89c1dd69b9b915d658ef17bca764393a884
+EBUILD arduino-ctags-20161123-r2.ebuild 968 BLAKE2B f5cb2261b578803c935d9a775d4e547e54116562b6736520ef4d705d56cfc1916f2eb0ea81bd8e10cfa02175e71533864c7c10b2f73193d8263ccca3b2806e89 SHA512 8f4f7ac67a915849098767d34a7aa25d53aba583bd9fcb5cb26800a55292bab5a737932b8a7ba7132344b19cfafac84c2c83eb0815086a3c53773a99a55b534c
MISC metadata.xml 638 BLAKE2B 9764b5ec67774239897874677669c351251b09dd2ad1008653aae1f90ac0af1604f531d905d2840825382c1a9afd1197d6f0d9b85d0c28d0cebc03f894dd8b4d SHA512 fe925e122838e294420ea0d89caf8d33c36c92c0711a409da1a4d46c60f00adb8984651b8f8231f01525f81e26bce20c8036c0ef12e1dc6996b98fd008121810
diff --git a/dev-embedded/arduino-ctags/arduino-ctags-20161123-r1.ebuild b/dev-embedded/arduino-ctags/arduino-ctags-20161123-r2.ebuild
index 116436b6fd42..77e78545e384 100644
--- a/dev-embedded/arduino-ctags/arduino-ctags-20161123-r1.ebuild
+++ b/dev-embedded/arduino-ctags/arduino-ctags-20161123-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit autotools
+
MY_COMMIT_HASH="abc8fca7499f44c725122881cd380a88c37abe0e"
DESCRIPTION="Arduino private fork of dev-util/ctags"
HOMEPAGE="https://github.com/arduino/ctags"
@@ -15,8 +17,15 @@ KEYWORDS="amd64 x86"
PATCHES=(
"${FILESDIR}"/${PN}-20161123-gcc-unused-attribute.patch
+ "${FILESDIR}"/${PN}-20161123-implicit-exit.patch
+ "${FILESDIR}"/${PN}-20161123-implicit-int.patch
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
--disable-readlib \
diff --git a/dev-embedded/arduino-ctags/files/arduino-ctags-20161123-implicit-exit.patch b/dev-embedded/arduino-ctags/files/arduino-ctags-20161123-implicit-exit.patch
new file mode 100644
index 000000000000..c14555ca503b
--- /dev/null
+++ b/dev-embedded/arduino-ctags/files/arduino-ctags-20161123-implicit-exit.patch
@@ -0,0 +1,21 @@
+diff '--color=auto' -ruN ctags-abc8fca7499f44c725122881cd380a88c37abe0e.orig/configure.ac ctags-abc8fca7499f44c725122881cd380a88c37abe0e/configure.ac
+--- ctags-abc8fca7499f44c725122881cd380a88c37abe0e.orig/configure.ac 2016-11-23 10:52:52.000000000 +0100
++++ ctags-abc8fca7499f44c725122881cd380a88c37abe0e/configure.ac 2024-11-05 00:53:01.050413525 +0100
+@@ -369,7 +369,8 @@
+ AC_EXEEXT
+
+ AC_MSG_CHECKING(if struct stat contains st_ino)
+-AC_TRY_COMPILE([#include <sys/stat.h>], [
++AC_TRY_COMPILE([#include <sys/stat.h>
++#include <stdlib.h>], [
+ struct stat st;
+ stat(".", &st);
+ if (st.st_ino > 0)
+@@ -449,6 +450,7 @@
+ AC_TRY_RUN([
+ #include <sys/types.h>
+ #include <regex.h>
++#include <stdlib.h>
+ main() {
+ regex_t patbuf;
+ exit (regcomp (&patbuf, "/hello/", 0) != 0);
diff --git a/dev-embedded/arduino-ctags/files/arduino-ctags-20161123-implicit-int.patch b/dev-embedded/arduino-ctags/files/arduino-ctags-20161123-implicit-int.patch
new file mode 100644
index 000000000000..5331df9db0d0
--- /dev/null
+++ b/dev-embedded/arduino-ctags/files/arduino-ctags-20161123-implicit-int.patch
@@ -0,0 +1,12 @@
+diff '--color=auto' -ruN ctags-abc8fca7499f44c725122881cd380a88c37abe0e.orig/configure.ac ctags-abc8fca7499f44c725122881cd380a88c37abe0e/configure.ac
+--- ctags-abc8fca7499f44c725122881cd380a88c37abe0e.orig/configure.ac 2024-11-05 00:55:57.281788938 +0100
++++ ctags-abc8fca7499f44c725122881cd380a88c37abe0e/configure.ac 2024-11-05 00:59:21.852536947 +0100
+@@ -451,7 +451,7 @@
+ #include <sys/types.h>
+ #include <regex.h>
+ #include <stdlib.h>
+-main() {
++int main() {
+ regex_t patbuf;
+ exit (regcomp (&patbuf, "/hello/", 0) != 0);
+ }],regcomp_works=yes,regcomp_works=no,AC_DEFINE(CHECK_REGCOMP))